Ubuntu 14.04 LTS与iOS7连接问题已经得到修复

Ubuntu 14.04 LTS目前依然在开发当中,由于使用了旧的库,会出现不能与iOS7设备连接的问题,但现在这一问题已经被开发者修复。

由于libimobiledevice 库很长时间没有更新,而旧的版本不支持IiOS7,所以当iOS7设备与电脑连接时,手机会弹出对话框提示是否信任该设备,用户点击信任后,Ubuntu并不能返回正确的信息,所以导致手机不能与电脑进行连接。

Launchpad上的开发者已经开发了一个新的libimobiledevice 库,并且已经经过了一系列的测试,但由于Ubuntu已经进行了feature freeze,所以并不能将该新版本的库加入官方库中,除非例外的将其加入官方库中。

不过在新的libimobiledevice 库加入官方库之前,大家依然可以通过PPA安装这个库来解决连接问题,打开终端(Terminal)执行以下命令来安装这个库:

sudo apt-add-repository ppa:timo-jyrinki/libimobiledevice

sudo apt-get update

sudo apt-get upgrade

安装了这个库之后,可能还会出一些问题,如果出现“lock down error”可以使用下面的命令解决:

sudo mkdir /var/lib/lockdown

sudo chmod 777 /va7Lib/lockdowno

如果要将这个库恢复到以前的版本,可以使用以下命令:

sudo apt-get install ppa-purge

sudo ppa-purge ppa:timo-jyrinki/libimobiledevice

如果依然出现问题,可以重启电脑或者登出重新登陆系统解决。

来源:softpedia    翻译及校对:Raint

0 0

Comments are closed.